Sie sind nicht angemeldet.

scotty86

Frisch Angeheuert

  • »scotty86« ist der Autor dieses Themas

Beiträge: 3

Registrierungsdatum: 28. Januar 2010

  • Nachricht senden

1

Donnerstag, 28. Januar 2010, 13:52

Speicher-Bug auch in 1.1

Moby-Dick hat ja ne schoene Bugliste, leider kann ich ihm keine PM schreiben

Zitat

Falls ich eine Bug-Meldung übersehe, bitte eine PM an mich
;)

Topic kann also gern gelöscht werden, wenn folgendes in die Bugliste aufgenommen wurde (oder auch nicht :P ) :

Folgender Bug tritt bei mir auch noch in der 1.1 auf:

Zitat

Das Spiel stürzt beim Speichern einfach ab (Savegame ist 5 kb groß und damit unbrauchbar).


Wobei die Savegames bei mir um die 50kb haben.

Mir ist aufgefallen, dass so laenger ich an einem Spiele spiele, desto oefter passiert der Fehler, bei meinem aktuellen Spiel fast jedes 3-4 Savegame... nervt langsam extrem...

Gruesse
scotty86

sebfriedrich

Insel-Eroberer

Beiträge: 448

Registrierungsdatum: 3. November 2009

  • Nachricht senden

2

Donnerstag, 28. Januar 2010, 14:02

ich hatte das bei meinem altem pc. das kam weil afm prozessor ne dicke staubschicht war und der lüfter es nicht geschaft hat ordentlich zu kühlen.
  Ich wünschte ich wäre abends so müde wie morgens

Leif Erickson

Insel-Eroberer

Beiträge: 399

Registrierungsdatum: 2. September 2009

  • Nachricht senden

3

Donnerstag, 28. Januar 2010, 14:16

Tritt bei mir auch noch auf (Patch 1.1). Mit dem neuen Endlosspiel weniger oft, aber so nach 4 Stunden spätestens raucht alles ab. Ich mach es so: Auf dem Desktop liegt eine Verknüpfung auf den savegames Ordner. Da kann ich immer nachsehen ob das letzte Savegame ok ist. Dann Autosave-Intervall auf 1 Stunde und nach dem 2. Autosave die Grösse überprüfen. Wenn alles ok ist, die aktuelle Aktion abschliessen, Quicksave (F5), nochmal prüfen und Anno neu starten. Wäre Anno 1404 nicht so ein tolles Spiel würde ich mir das nicht antun. Aber Prozessor entstauben könnte eine Idee sein...
Ich denke mal, der Faden passt ins Technik-Forum...Regie, bitte schneiden, bitte schneiden...
  Ich! Werde! Nicht! Singen!

Larnak

Schatzjäger

Beiträge: 3 126

Registrierungsdatum: 28. Februar 2008

  • Nachricht senden

4

Donnerstag, 28. Januar 2010, 14:27

Meiner Erfahrung nach hilft es, wenn man bei solchen Problemen (Abstürze + Speicherprobleme nach längerer Spieldauer) Anno nach 1-2 Stunden (je nachdem, wann die Probleme auftauchen) das Spiel zu speichern, Anno auszuschalten und wieder neu zu starten.
Das hat bei mir immer funktioniert.

PS: Moby ist kein "ihm", sondern eine "ihr" :up:

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Larnak« (28. Januar 2010, 14:28)


Amelie

Schatzjäger

Beiträge: 1 453

Registrierungsdatum: 5. November 2006

  • Nachricht senden

5

Donnerstag, 28. Januar 2010, 14:30

Scotty86,
Moby ist eine sie :hey:

und häng mal an deinen nächsten Beitrag das an Wie hänge ich meine dxdiag an meinen Post?

exxonic

Schatzjäger

Beiträge: 1 479

Registrierungsdatum: 10. Oktober 2009

  • Nachricht senden

6

Donnerstag, 28. Januar 2010, 15:06

ich hatte (ohne patch) nur probleme beim speichern, wenn ich einen spielstand ueberschrieben hab. dabei stuerzte mein spiel dann oft ab, oder wenn es das nicht tat, war der spielstand unbrauchbar. hab mir angewoehnt nur neue spielstaende anzulegen. muss halt ab und zu mal aufgeraeumt werden ; )
 

Str1per

Vollmatrose

Beiträge: 142

Registrierungsdatum: 8. Juli 2009

  • Nachricht senden

7

Donnerstag, 28. Januar 2010, 22:07

Ich weiss nicht, wo ich es gelesen habe, aber irgendwo stand, man soll keine speicherstände überschreiben. Habe ich noch nie und habe auch noch nie (3*holzklopf) einen kaputten Speicherstand gehabt. Hab gestern dann erst wieder 1 Gig Saves gelöscht :D.

morti271

Is Seefest

Beiträge: 46

Registrierungsdatum: 4. Juli 2009

  • Nachricht senden

8

Donnerstag, 28. Januar 2010, 22:23

Wäre wirklich seltsam, wenn es an der Überhitzung des Prozessors liegen würde. Da würde wohl eher Anno während des Spielens abschmieren, als dass der PC es nicht mehr schafft ein Spiel zu speichern.
Meiner Erfahrung nach liegt es auch an der Spieldauer, da sich mit der Zeit wahrscheinlich immer mal wieder kleine Fehler einschleichen (evtl. durch überfüllten RAM) und dann eben zum defekten Savegame führen.

IceMan

Schatzjäger

Beiträge: 4 979

Registrierungsdatum: 3. November 2007

  • Nachricht senden

9

Freitag, 29. Januar 2010, 11:06

Nur mal ein Einwurf.

Auch das Überspeichern von Spielständen funktioniert auf Rechnern, die nicht das Speicherproblem haben, reibungslos.
  Timeo Danaos et dona ferentes.

werkoe

Meereskenner

Beiträge: 735

Registrierungsdatum: 17. Juli 2009

  • Nachricht senden

10

Freitag, 29. Januar 2010, 11:14

:D Joo, das kann ich bestättigen. Habe sogar schon mit 10 x Überschreiben probiert, ein Save kaputt zu bekommen, nix dergleichen. :maeh:
  Kapitano, A.D.
_______________
Anno 1404: Erfolge...Online --> weko-one 2
Ohne Mods..mit AV 2.01...Silbernen Schiff und Wappen :))
Anno 2070: Erf. --> 114/117......Her. --> 30/35......Geh. --> 55/59

Picklock

Schatzjäger

Beiträge: 1 275

Registrierungsdatum: 7. Februar 2006

  • Nachricht senden

11

Freitag, 29. Januar 2010, 21:02

Ich kann die Vorposter auch nur bestätigen. Hatte noch keinen defekten Speicherstand und hatte sowohl Speicherstände überschrieben, als auch 100 oder mehr Saves im Savegames Ordner.

scotty86

Frisch Angeheuert

  • »scotty86« ist der Autor dieses Themas

Beiträge: 3

Registrierungsdatum: 28. Januar 2010

  • Nachricht senden

12

Samstag, 30. Januar 2010, 10:43

Fuer den Geschlechts-Fauxpas möchte ich mich entschuldigen +schaem+


Mit dem Prozessor ist auszuschliessen, der ist prime-stable und bei weitem nicht ausgelastet.

Mit dem Überschrieben ist ein Ansatz, da ich mich nur auch autosave verlasse (man vergisst ja so schnell die Zeit ;D)
Autosave-Rate runter zu stellen, trau ich mich nicht, 30min Spielverlust sind schon ärgerlich, bei 1h würde ich das Spiel glaub verbrennen :D

Zu guggen ob das Savegame OK is bringt nichts, da Anno, wenn das Savegame kaputt ist, immer abschmiert.

Mal kucken ob ich ne Option finde, dass er für autosaves immer eine neue Datei anlegt, zu not schreib ich mal ein Programm, was die älteren autosaves löscht.


Werde mich bei neuen Erkenntnissen wieder melden.

Schiff ahoi ;)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »scotty86« (30. Januar 2010, 10:44)


IceMan

Schatzjäger

Beiträge: 4 979

Registrierungsdatum: 3. November 2007

  • Nachricht senden

13

Samstag, 30. Januar 2010, 12:14

@ scotty86,

ein autosave schreibt meines Wissens IMMER eine neue Datei.
  Timeo Danaos et dona ferentes.

plastefuchs

Plankenstürmer

Beiträge: 32

Registrierungsdatum: 26. Juli 2009

  • Nachricht senden

14

Samstag, 30. Januar 2010, 14:53

er meinte glaub ich, dass anno jeweils die datei "Autosave_0_XYZ.sww" immer wieder nur überschreibt
bei mir is das jedenfalls so, dass es nur 3 Dateien (mit ..._0_, _1_ und _2_ ) gibt, die abwechselnd überschrieben werden.
das war auch schon meine vermutung. allerdings kommt das nicht so ganz hin. allgemein hab ich den Eindruck, dass sich mit steigender Spieldauer (also auch insgesamt und nicht nur pro "Session") die Abstürze häufen. bei mir hat der Patch auf alle Fälle nix geholfen. hätte ich gewusst, dass man besser keine Umlaute im Profilnamen verwendet, hätt ichs gelassen.

Larnak

Schatzjäger

Beiträge: 3 126

Registrierungsdatum: 28. Februar 2008

  • Nachricht senden

15

Samstag, 30. Januar 2010, 15:21

Wie ich schon oben gesagt habe:
Bei mir half es, nach jedem Autosave Anno direkt neu zu starten, Autosave hatte ich auf eine Stunde gestellt.

Wenn ich länger spielte, ohne neu zu starten, bekam ich ähnliche Probleme.

Ist zwar nicht ideal und etwas nervig, aber wenn's doch hilft. :keineahnung:
Kannst es ja mal probieren, wenn Du keine andere Lösung findest.

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Larnak« (30. Januar 2010, 15:22)


ChaosKlinik

Meereskenner

Beiträge: 723

Registrierungsdatum: 5. August 2009

  • Nachricht senden

16

Samstag, 30. Januar 2010, 15:22

Jede Stunde neuzustarten ist aber doch ganz schön stressig?

Alle 2 Stunden würde ich machen, allerdings hatte ich noch nie einen Speicherbug, obwohl ich überschreibe.

Larnak

Schatzjäger

Beiträge: 3 126

Registrierungsdatum: 28. Februar 2008

  • Nachricht senden

17

Samstag, 30. Januar 2010, 15:48

Das kommt auf das Problem an. 2 Stunden habe ich probiert, da hatte ich dann aber schon Abstürze und Save-Probleme. Ich bin also wieder auf eine Stunde zurückgekehrt.

Und stressig ist das nicht, eher das Gegenteil.

scotty86

Frisch Angeheuert

  • »scotty86« ist der Autor dieses Themas

Beiträge: 3

Registrierungsdatum: 28. Januar 2010

  • Nachricht senden

18

Samstag, 30. Januar 2010, 16:16

jo, genau plastefuchs, das meinte ich

Hab etz mal ein kleines Tool geschrieben, dass das älteste der drei autosaves automatisch löscht.

Funktioniert so weit problemlos, hab das Spiel mal 'herrenlos' zwei Stunden, mit autosave auf 15min, laufen lassen und es ist nicht abgekackt, werd es morgen mal unter 'realen' Bedinungen testen, wenn ich spiele.

Die exe muss in das Anno-Spieleverzeichnis.
Sichert bitte vorher eure savegames!!!
Dann einfach Anno_Savegame_Cleaner.exe starten.
Kurz schauen, ob in dem Textfeld der korrekte Pfad zu euren Savegames steht.
Dann einfach Start drücken und Anno startet.
Ab jetzt wird jede Minute geschaut, ob ein neues Autosave erstellt wurde, wenn drei existieren, wird das älteste gelöscht (bis jetzt werden nur Endlosspiele überprüft, also die Dateien "autosave_ZahlVon0Bis2_EuerName.sww").

Benutzung auf eigene Gefahr ;)

Wenns Probleme oder positive Erfahrungen gibt bitte kurz berichten.

Grüße
scotty86
»scotty86« hat folgende Datei angehängt:

Moby-Dick

Schatzjäger

Beiträge: 2 351

Registrierungsdatum: 5. Juni 2003

  • Nachricht senden

19

Sonntag, 31. Januar 2010, 09:30

RE: Speicher-Bug auch in 1.1

Zitat

Original von scotty86
Moby-Dick hat ja ne schoene Bugliste, leider kann ich ihm keine PM schreiben


Ich bin nicht mehr Admin und kann somit auch keine Posts ändern ;) .... wenn weitere nicht aufgeführte Bugs auftauchen, wendet Euch bitte an jemandem aus dem Team

zero1000

Ausguck

Beiträge: 95

Registrierungsdatum: 26. Februar 2003

  • Nachricht senden

20

Mittwoch, 17. Februar 2010, 10:10

Hier meine Erfahrungen zum Speicherbug:

Tritt in meinem aktuellen Endlosspiel (mit P1.1 und WorldEditor und ToolOne und Mods) nach ca. 30h Spielzeit mit ca. 50% Wahrscheinlichkeit auf.

Dabei ist es egal, ob eigenes Save erstellt oder überschrieben wird, oder Quicksave oder Autosave erstellt oder überschrieben wird.

Ich habe mir auch angewöhnt, nach dem Speichern einfach auf die Größe des Saves zu schauen, < 100K = kaputt, > einige zig MB = OK.

Nur tritt es immer öfter auf, dass der Speicherbug auch merhfach direkt hintereinander auftritt, so dass ich mehrere kaputte Saves auf der Platte habe und dann während des Speicherns auch noch ein BackToDesktop dazukommt - Also trotz Checks der Größe des Saves am Ende doch wieder 1 oder 2h umsonst gespielt :aua:

Wenn das jetzt noch weiter zunimmt, dann muß ich wohl, sosehr ich das Spiel mag (nicht zuletzt wegen der genialen Mods), wohl wieder was anderes spielen ?(
 
- - - zero1OOO
- - -
__________________