Sie sind nicht angemeldet.

Reisiii

Frisch Angeheuert

  • »Reisiii« ist der Autor dieses Themas

Beiträge: 2

Registrierungsdatum: 29. April 2018

  • Nachricht senden

1

Sonntag, 29. April 2018, 13:48

Hilfe beim Anno 1404 Editor 2

Hey Leute ich habe neulich wieder angefangen Anno 1404 bei Uplay zu zocken (wegen Hype auf 1800) und wollte mir mal den World editor downloaden und diesen Installieren jedoch kann ich die entwicklertools nicht installieren (Anno 1404 und Anno 1404 Venedig)
Es steht "Die Setup hat festgestellt, dass keine Version von Anno 1404 installiert ist, Für dieses Update muss eine Version vorhanden sein..."

habe Win10
Spiel bei Uplay installiert
Screenshot:
http://prntscr.com/jbk7vs

Wäre nice wenn mir jemand helfen könnte!
L.G Reisi

Soricida

Meereskenner

Beiträge: 703

Registrierungsdatum: 30. Dezember 2011

  • Nachricht senden

2

Sonntag, 29. April 2018, 21:50

Hallo Reisiii,
willkommen in der Annozone

Ich vermute mal, Du hast jetzt das gleiche Problem wie die Anno-Spieler mit Steam.
Da kam es durch andere Registry-Einträge (wie von der DVD-Version) dazu!
Und die Editor-Tools suchen nur nach den Einträgen der DVD-Version.

Hast Du schon mal bei einem Windows mit der Registry gearbeitet?

Wenn Dein Problem die gleiche Ursache hat, dürfte Dir dieser Beitrag hier helfen >
Anno 1404 Steam, keinen registry eintrag
aber bei Uplay gibt es garantiert wieder einen anderen Uninstall-Eintrag,
den man erst mal finden und dann wie dort beschrieben ändern muß.

Gruß
Soricida
  Ich bin ja nicht neugierig, aber wissen möchte ich es schon!

Reisiii

Frisch Angeheuert

  • »Reisiii« ist der Autor dieses Themas

Beiträge: 2

Registrierungsdatum: 29. April 2018

  • Nachricht senden

3

Montag, 30. April 2018, 09:27

funktioniert immer noch nicht

Soricida

Meereskenner

Beiträge: 703

Registrierungsdatum: 30. Dezember 2011

  • Nachricht senden

4

Montag, 30. April 2018, 20:46

Und was hattest Du gemacht?
  Ich bin ja nicht neugierig, aber wissen möchte ich es schon!

Hegona

Leichtmatrose

Beiträge: 10

Registrierungsdatum: 8. April 2019

  • Nachricht senden

5

Montag, 8. April 2019, 13:32

Ich habe leider das selbe problem dise Steam einträge sind vorhanden die musste ich garnicht erstelllen ist halt echt schade...
hat noch wer ne idee?
LG
Hegona

Soricida

Meereskenner

Beiträge: 703

Registrierungsdatum: 30. Dezember 2011

  • Nachricht senden

6

Montag, 8. April 2019, 21:35

Hallo Hegona,
willkommen in der AnnoZone

Anno 1404 Steam, keinen registry eintrag
Dieses Thema wurde leider nicht ganz korrekt benannt.
Statt "keinen" hätte es andere, fehlende, oder ... heißen müssen!
Steam hat natürlich auch alle nötigen Einträge in die Registry geschrieben,
die man zum Spielen, oder Deinstallieren braucht. Aber eben andere als UBI.
Wenn Steam-Anno 1404-Spieler die Entwicklertools installieren wollen, müssen
sie die beiden nötigen Registry-Einträge der UBI-Version selber erstellen!!!

Wie es gemacht werden sollte steht in dem Link.
(Eine andere Variante wurde dort auch noch verlinkt.)

Wenn Du noch weitere Fragen dazu hast, dann stelle sie bitte dort.

Gruß
Soricida
  Ich bin ja nicht neugierig, aber wissen möchte ich es schon!

Hegona

Leichtmatrose

Beiträge: 10

Registrierungsdatum: 8. April 2019

  • Nachricht senden

7

Dienstag, 9. April 2019, 07:03

Moin und danke das ich hier sein darf das es euch gibt

sry was ich vergessen habe ist ich spiele über uplay :) und da sind allle vorhanden nur halt an anderen orten bis auf hier
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\ Windows\CurrentVersion\Uninstall\
da habe ich gar nix von anno oder ubi soft drin....

Soricida

Meereskenner

Beiträge: 703

Registrierungsdatum: 30. Dezember 2011

  • Nachricht senden

8

Dienstag, 9. April 2019, 21:11

Moin Hegona,

andere Orte oder fehlende Einträge sind ja auch der Grund für dieses Dilemma...

Um die Tools zu installieren, benötigt man folgende Einträge in der Registry:
1. [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Ubisoft\Anno 1404\GameUpdate] und
2. [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\ Windows\CurrentVersion\Uninstall\{3D9CF3CA-3AB0-4A82-9853-D7C43FD1D775}]

Was in dem 1. enthalten sein muß, habe ich in dem anderen Thema als .txt angehängt ( Beitrag # 21 ).
Wenn der Installationsort jedoch davon abweicht, muß es noch entsprechend geändert werden!

In den 2. muß man als Steam-Benutzer das einfügen, was unter folgendem Eintrag steht.
(B.z.w. beim exportierten Registryschlüssel die beiden Zeilen austauschen.)
"HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\ Windows\CurrentVersion\Uninstall\Steam App 33250"

Ich hoffe mal, dieser Eintrag von Steam existiert doch auch bei Dir!

Gruß
Soricida
  Ich bin ja nicht neugierig, aber wissen möchte ich es schon!

Hegona

Leichtmatrose

Beiträge: 10

Registrierungsdatum: 8. April 2019

  • Nachricht senden

9

Mittwoch, 10. April 2019, 06:35

wie oben schon geschrieben ich benutze kein STeam daher auch keinen Steam eintrag........ Uplay ist der launcher
deswegen habe ich dieses hier zur auswahl nur was da ändern?

Annofighter

Frisch Angeheuert

Beiträge: 4

Registrierungsdatum: 10. April 2019

  • Nachricht senden

10

Mittwoch, 10. April 2019, 12:39

wie oben schon geschrieben ich benutze kein STeam daher auch keinen Steam eintrag........ Uplay ist der launcher
deswegen habe ich dieses hier zur auswahl nur was da ändern?

Also ich kann hier wenig Hoffnung verbreiten. Nach Tagelanger Suche und diversen Einträge - Installationen komme ich nicht weiter. Ich habe Anno 1404 sowohl von Steam als auch von Ubisoft. Beide lassen die Installation des Editors nicht zu. Auch habe ich die Version 1.1 und 1.2 probiert. Keine Chance. Aber alles nur unter Windows 10. Ob es mit Win 7 geht, keine Ahnung.

Falls jemand selber Win 10 und mit diesen Einträgen Erfolg hatte - bitte bitte melden. Das 1404 ist echt so schön zu spielen und hier Karten erstellen zu können wäre wie Weihnachten.

Grüße

Annofighter

Frisch Angeheuert

Beiträge: 4

Registrierungsdatum: 10. April 2019

  • Nachricht senden

11

Mittwoch, 10. April 2019, 21:40

Hier eine erfreuliche Nachricht. Habe Anno 1404 und das Addon wieder zu Hause gefunden (DVD). Habe es unter Win 10 installiert. Was soll ich sagen-läuft. Das Beste :-) Der World Editor lässt sich installieren und läuft!!!!!!!

Hurra :wedel: :wedel: :wedel: :wedel: :wedel:

Soricida

Meereskenner

Beiträge: 703

Registrierungsdatum: 30. Dezember 2011

  • Nachricht senden

12

Mittwoch, 10. April 2019, 22:19

Sorry Hegona,

vorher "Wiederherstellungspunkt" erstellen?!!!

ich habe mal versucht für den 1. Eintrag die Pfade an Deine Installation anzupassen.(Anhang ...txt in ...reg umbenennen und [als Admin ?] ausführen.)

Für den 2. Eintrag (rechtsklick) exportiere mal genau diesen "Uplay Install 89".
Dann bei dieser Datei das .reg in .txt ändern und die erste Zeile unter
"Windows Registry Editor Version 5.00" löschen und dafür diese einfügen...
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{3D9CF3CA-3AB0-4A82-9853-D7C43FD1D775}]
Speichern unter... , dann wieder umbenennen von ...txt in ...reg und [als Admin ?] ausführen.

Neu starten und das Toolset1.2 installieren.

Hoffe es geht dann ...
Gruß
Soricida

Edit: Datei entfernt und weiter unten geändert wieder angehängt.
  Ich bin ja nicht neugierig, aber wissen möchte ich es schon!

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Soricida« (4. Mai 2019, 23:19)


Annofighter

Frisch Angeheuert

Beiträge: 4

Registrierungsdatum: 10. April 2019

  • Nachricht senden

13

Donnerstag, 11. April 2019, 09:07

Hallo,

Ich habe eine zweite Partition (Laufwerk D) indem meine Spiele installiert sind. Diesen Pfad ggf. auf C: ändern.

nach der Installation von der DVD schaut bei mir der Registry Eintrag für 3D9CF3CA-3AB0-4A82-9853-D7C43FD1D775 so aus:


[HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall\{3D9CF3CA-3AB0-4A82-9853-D7C43FD1D775}]
"ModifyPath"="\"C:\\Program Files (x86)\\InstallShield Installation Information\\{3D9CF3CA-3AB0-4A82-9853-D7C43FD1D775}\\setup.exe\" -runfromtemp -l0x0407 "
"UninstallString"="\"C:\\Program Files (x86)\\InstallShield Installation Information\\{3D9CF3CA-3AB0-4A82-9853-D7C43FD1D775}\\setup.exe\" -runfromtemp -l0x0407 -removeonly"
"LogFile"="C:\\Program Files (x86)\\InstallShield Installation Information\\{3D9CF3CA-3AB0-4A82-9853-D7C43FD1D775}\\setup.ilg"
"InstallLocation"="D:\\Program Files (x86)\\Ubisoft\\Ubisoft Game Launcher\\Anno 1404"
"ProductGuid"="{3D9CF3CA-3AB0-4A82-9853-D7C43FD1D775}"
"DisplayName"="ANNO 1404"
"Publisher"="Ubisoft"
"DisplayIcon"="D:\\Program Files (x86)\\Ubisoft\\Ubisoft Game Launcher\\Anno 1404\\Anno4.exe,0"
"Language"=dword:00000407
"DisplayVersion"="1.03.0000"
"Version"=dword:01030000
"LogMode"=dword:00000001
"NoModify"=dword:00000001
"NoRepair"=dword:00000001
"VersionMajor"=dword:00000001
"VersionMinor"=dword:00000003

Hegona

Leichtmatrose

Beiträge: 10

Registrierungsdatum: 8. April 2019

  • Nachricht senden

14

Donnerstag, 11. April 2019, 13:05

leider immernoch :( tut mir leid aber danke das du so viel arbeit rein gesteckt hast .......
@Annofighter kannst du die datei mal exportieren und hier hoch laden in einen beitrag?

Hegona

Leichtmatrose

Beiträge: 10

Registrierungsdatum: 8. April 2019

  • Nachricht senden

15

Donnerstag, 11. April 2019, 14:05

JAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA das war es er macht es habe einfach 1 zu 1 deine datei benutzt

Annofighter

Frisch Angeheuert

Beiträge: 4

Registrierungsdatum: 10. April 2019

  • Nachricht senden

16

Mittwoch, 17. April 2019, 20:38

Hey super, dann haben wir beide endlich etwas davon. Jetzt bin ich nur noch am werkeln mit den Maps für ein Multiplayer Game. Das ist echt Mist mit Anno1404. Bei Anno 1701 ist es so leicht mit dem Editor.....

Freut mich jedenfalls, dass es jetzt schon mal eine einfache Lösung gibt. :up: :up: :up:

husar84

Frisch Angeheuert

Beiträge: 7

Registrierungsdatum: 3. Mai 2019

  • Nachricht senden

17

Samstag, 4. Mai 2019, 11:27

Servus alle,
ich habe genau das gleiche
Problem wie Hegona. Kannst du mir bitte auch weiterhelfen? Ich habe die
Beiträge hier gelesen aber ich werde leider nicht schlau drauß. Ich habe
das spiel über Ubisoft installiert den WorldEditor v1.2 für das Addon
runtergeladen. Und was muss ich jetzt tun?
Eigentlich möchte ich nur eine bestimmte Zufallsmap etwas anpassen aber ohne Editor keine Chance.Grüße Marc

Soricida

Meereskenner

Beiträge: 703

Registrierungsdatum: 30. Dezember 2011

  • Nachricht senden

18

Sonntag, 5. Mai 2019, 00:00

Hallo husar,
willkommen in der AnnoZone

Ich habe den (Uninstall)Eintrag von Annofighter in eine ...reg Datei umgewandelt.
Darin sind Installations-Pfade die bei jedem anders sein können!
Diese Pfade müssen mit Eurer Installation übereinstimmen, oder entsprechend angepaßt werden!
Ich habe sie mal wieder auf Laufwerk C: geändert. Z.B.
"InstallLocation"="C:\\Program Files (x86)\\Ubisoft\\Ubisoft Game Launcher\\Anno 1404"
"DisplayIcon"="C:\\Program Files (x86)\\Ubisoft\\Ubisoft Game Launcher\\Anno 1404\\Anno4.exe,0"
Und für den (Update)Eintrag ebenso.
"execPath"="C:\\Program Files (x86)\\Ubisoft\\Ubisoft Game Launcher\\upc.exe" uplay\\uninstall\\89
"installdir"="C:\\Program Files (x86)\\Ubisoft\\Ubisoft Game Launcher\\Anno 1404"

Du mußt diese ...txt Dateien kontrollieren, eventuell anpassen, als ...reg speichern und diese dann ausführen (importieren).
Wenn alles richtig ist, kann man anschließend die Tools installieren. Und dann viel Spaß...

Gruß
Soricida
»Soricida« hat folgende Dateien angehängt:
  Ich bin ja nicht neugierig, aber wissen möchte ich es schon!

husar84

Frisch Angeheuert

Beiträge: 7

Registrierungsdatum: 3. Mai 2019

  • Nachricht senden

19

Montag, 6. Mai 2019, 08:29

Also nochmal vielen Dank Soricida mit deinen beiden Files habe ich es hinbekommen und jetzt auch verstanden. Der World Editor und ToolOne funktionieren :thumbsup:.
Grüße
Marc

MrXfox

Landratte

Beiträge: 1

Registrierungsdatum: 16. Juni 2019

  • Nachricht senden

20

Gestern, 13:36

Vielen dank von einem Anno wieder Entdecker

Hallo husar,
willkommen in der AnnoZone

Ich habe den (Uninstall)Eintrag von Annofighter in eine ...reg Datei umgewandelt.
Darin sind Installations-Pfade die bei jedem anders sein können!
Diese Pfade müssen mit Eurer Installation übereinstimmen, oder entsprechend angepaßt werden!
Ich habe sie mal wieder auf Laufwerk C: geändert. Z.B.
.........
Puh du hast mich echt gerettet, danke dir :) cool das die Fanbase um die Serie noch so groß ist und auch so aktiv. Okay gab ja auch mit 1800 erst Nachschub. Muss dazu sagen, Kenne Anno praktisch schon immer und bin damit aufgewachsen war aber damals beim ersten teil 4 oder 5 und fand immer nur die Städte die ich bei meinem Vater gesehen hatte total schön. selbst 1503 hatte ich nicht so recht drauf und bin nicht weiter als bis zu Tier 2 gekommen. Nun hatte ich die Serie aber mit 1800 wieder entdeckt und komme jetzt auch bis ans ende und will jetzt natürlich alles nachholen und bin an 1404 irgendwie etwas kleben geblieben, was mir einfach von setting her sehr gefällt .... da ich auch über uplay spiele(hab sogar die disc version hier, nur ich hab kein cd rom laufwerk am pc -.- ) hast du mir echt ungemein weiter geholfen. Und als ich gesehen hatte das der post noch gar nicht sooo alt war, dachte ich ich bedanke mich mal und erstelle mir einfach mal einen Account wer weiß was ich hier noch so alles finde auf meiner Reise ;)