You are not logged in.

anno-michi

Boardsmutje

  • "anno-michi" started this thread

Posts: 889

Date of registration: Oct 27th 2009

  • Send private message

1

Thursday, January 10th 2019, 12:04am

Problem mit Anno 1503, Windows 10 und Fraps (Bildschirmaufnahme)

Habe nun endlich auch ANNO 1503 auf meinem neuen PC installiert und es läuft alles so wie es soll - super!

Einige von euch wissen bestimmt, dass ich einen YouTube-Kanal betreibe, wo ich Anno (hauptsächlich 1503) let's-playe. Um ein gerade laufendes LP weiterzuführen, muss ich das Spiel auch mit einer Software aufzeichnen können: Hierfür habe ich auf meinem alten PC (Win 7) mit dem Programm "Fraps" sehr positive Erfahrungen gemacht, was die Aufnahmequalität betrifft.

Da ich auf dem neuen PC aber auf eine modernere Aufnahme-Software (OBS) umgestiegen bin, dachte ich zuerst, dass ich Fraps wohl nicht mehr brauche.
Leider kann OBS ANNO 1503 nur im Fenstermodus aufnehmen. Das klappt auch ganz gut, einziger Nachteil ist, dass ich das Video vom Fenstermodus vergrößern muss, damit es bildschirmfüllend ist, was Einbußen in der Videoqualität mit sich bringt. Diese sind zwar nur minimal, aber im direkten Vergleich mit den Fraps-Videos auf meinem Kanal ist der Unterschied deutlich erkennbar.

Also habe ich Fraps wieder installiert und hier fängt das Problem an:
Wenn ich Anno starte, komme ich ganz normal ins Menü - aber sobald ich eine Karte ausgewählt habe und er Ladebildschirm erscheint und das Spiel zu Ende geladen hat, bleibt Anno "stehen". Die Musik geht zwar noch so lange weiter, bis das Stück fertig ist, aber danach geht nichts mehr. Via strg+alt+entf komme ich nicht mehr in den Taskmanager, auch mit der Windowstaste lässt sich Anno nicht mehr minimieren. (Hier blendet sich aber zumindest die Taskleiste ein, worüber ich den PC neu starten kann)

Wenn ich Fraps nicht aktiviere, lässt sich Anno normal spielen, sobald Fraps im Hintergrund offen ist, habe ich dieses Problem.
Um mehr über das Problem herauszufinden, habe ich versucht, Anno zu starten, es im Startmenü zu minimieren, Fraps zu starten und dann wieder auf Anno zurück zu kehren. Hierbei hat mir Fraps dann eine Fehlermeldung ausgespuckt, die ich hier im Post angehängt habe. Scheint wohl irgendwas mit DirectX zu tun zu haben? Ich kenne mich da leider überhaupt nicht aus.

Ich weiß dieses Problem ist sehr spezifisch und möglicherweise gibt es dafür auch keine Lösung, aber ich wollte mal hier reinfragen, ob jemand das Problem kennt, oder Ideen hat, was man da machen kann, damit sich Anno trotz Fraps im Hintergrund spielen lässt.
Kennt ansonsten jemand alternative Bildschirmaufnahmeprogramme die ich probieren könnte?
anno-michi has attached the following image:
  • fraps.PNG
anno-michi has attached the following file:
  • DxDiag.txt (77.43 kB - 23 times downloaded - latest: May 11th 2019, 3:34am)
  Spannende ANNO 1503 Let's Plays gibts auf meinem YouTubeChannel! :up:
Schau doch mal vorbei!

GabiB

Schatzjäger

Posts: 1,955

Date of registration: Nov 9th 2003

  • Send private message

2

Thursday, January 10th 2019, 1:14am

Ich bin deswegen auf Bandicam umgestiegen. Kann mann sowohl Screens als auch Videos machen damit.
  :engel:

Gute Mädchen kommen in den Himmel, böse überall hin! Sprichwort

octo124

SeeBär

Posts: 250

Date of registration: Jan 13th 2007

  • Send private message

3

Thursday, January 10th 2019, 4:49am

Abgesehen von deinem speziellen Problem solltest du dich mal um dein System kümmern.

Fürs BIOS gibts zu diesem Board inzwischen die Version F11, du hast noch F1?!!!!. Dito natürlich auch zig aktuellere Treiber vom Boardhersteller. In diesem Zusammenhang überlegen, ob das automatische Treiberupdate von W10 unterbunden werden sollte. Finger weg von Progs ala DriverBoost etc., sondern das macht man manuell.

Weiterhin gibts in deiner DxDiag mindestens 2 Bluescreens bei den letzten 10 Ereignissen. Ich vermute mal, dass du in der bisherigen Lebenszeit des PC´s noch zig andere hattest.
Und genau hier sollte zuerst zur Systemreperatur angesetzt werden. Wenn möglich, dann packe die letzten 5 Minidumps als Zip-Archiv und lade sie mal hier hoch. Wo zu finden, steht in der DxDiag unten.
Bluescreens sind in der Regel ein selbstverschuldetes Elend = ist das System + Programme richtig konfiguriert, stimmt die Hardware als Gesamtpaket überein, dann gibt es keine BSD.

Gib bitte Infos, ob es sich um einen Fertig-PC handelt mit vorinstalliertem BS bzw. Selbstbau. Lese bitte mit CPU-Z die Part-Nr. aller verbauten RAM-Riegel aus, vergleiche deren Nummer und poste diese.

Raymond XX

Boardsmutje

Posts: 991

Date of registration: Jan 23rd 2011

  • Send private message

4

Thursday, January 10th 2019, 9:41am

Moin,

@Anno-Michi: Du kannst doch DirectX 9 Nachinstallieren. Gehe dazu auf die Downloadseite von MS und suche nach der SDK DirectX9. Diese dann installieren und et voila, dürfte Fraps laufen.

Aber erst die Probleme beseitigen die der octo124 angesprochen hatte. Sonst haste da nicht lange Freude dran.
  Anno 1503 / AddOn; Anno 1701 KE; Anno 1404 / Add On; :up: Anno 2070 KE / Anno 2205 KE :hauwech:

Barbarella

Schatzjäger

Posts: 1,407

Date of registration: Jul 2nd 2005

  • Send private message

5

Thursday, January 10th 2019, 6:40pm

Fraps unterstützt kein Windows 10, maximal Windows 7. Die letzte Version ist von 2013. Das Programm kommt mit den höheren DirectX-Versionen wahrscheinlich nicht klar. Es erwartet DirectX 9, du hast aber DirectX 12. Und mit jedem Patchday, mit jedem Featureupdate entfernt sich Windows 10 weiter vom technologischen Stand von 2013 und damit von Fraps.

Vergiss also Fraps. Es stirbt zusammen mit Windows 7, falls der Entwickler es nicht auf einen aktuellen Stand bringt. Du brauchst etwas, das Windows 10-kompatibel ist.

Barbarella

Schatzjäger

Posts: 1,407

Date of registration: Jul 2nd 2005

  • Send private message

6

Thursday, January 10th 2019, 8:06pm

Ich habe bisher das Aufzeichnen von Spielen immer so ein bisschen vor mir her geschoben. Etwas, dass ich immer mal ausprobieren wollte aber nie angefangen habe. Aber siehe da, geht ganz einfach. Mit der Spieleleiste von Windows 10. Guckst du:

https://1drv.ms/u/s!AsQQ_CliL2L6gZQ6VDr-c__RNpdgOw


Geht auch mit Anno 1503. Das ist aber etwas zickiger. Die Videos am Anfang kommen damit nicht klar. Außerdem gibt es ein Problem, wenn man ein gespeichertes Spiel ladet. Dabei schaltet das Spiel offenbar in eine andere Bildschirmauflösung, wodurch die Aufzeichnung beendet wird. Wenn man aber mit dem Start der Aufzeichnung wartet, bis das Spiel geladen ist und läuft, funktioniert die Aufzeichnung einwandfrei:

https://1drv.ms/u/s!AsQQ_CliL2L6gZQ7KuSwZ4V9Pya67g

anno-michi

Boardsmutje

  • "anno-michi" started this thread

Posts: 889

Date of registration: Oct 27th 2009

  • Send private message

7

Sunday, January 13th 2019, 10:18pm


Fürs BIOS gibts zu diesem Board inzwischen die Version F11, du hast noch F1?!!!!

Danke für diesen Hinweis, das ist mir garnicht aufgefallen! Habe nun das aktuelle BIOS (F11) installiert.



Wenn möglich, dann packe die letzten 5 Minidumps als Zip-Archiv und lade sie mal hier hoch. Wo zu finden, steht in der DxDiag unten.

Leider ist mein Minidump-Ordner leer. Keine Ahnung wieso. (Versteckte Dateien sind auf "sichtbar")
Da ich den PC noch nicht sehr lange habe, gab es nur diese zwei Bluescreens, mehr nicht.



Gib bitte Infos, ob es sich um einen Fertig-PC handelt mit vorinstalliertem BS bzw. Selbstbau.

Der PC ist ein Selbstbau. Das Betriebssystem habe ich via USB Stick aufgespielt.



Lese bitte mit CPU-Z die Part-Nr. aller verbauten RAM-Riegel aus, vergleiche deren Nummer und poste diese.

Ich hab dir mal den gesamten CPU-Z Log angehängt. Für meinen Teil kenn ich mich Hardwaretechnisch leider nicht wirklich gut aus, sollte irgendwas nicht passen freue ich mich sehr über deine Hilfe!

-----

@Barbarella

Da hast du Recht, Fraps ist tatsächlich schon sehr alt und wird seit 2013 auch nicht mehr geupdatet.
Wie du richtig sagst ist es jetzt spätestens mit Win10 n der Zeit, nach einem alternativen Programm Auschau zu halten...
Eigentlich eh dumm von mir, dass ich das nicht bedacht habe bevor ich den Thread hier eröffnet habe^^

Was die Windows-interne Aufnahmefunktion betrifft sieht das eigentlich ganz gut aus, ABER ich bin mit der Videoqualität nicht ganz zufrieden. (Vor allem beim rein/rauszoomen sieht man eine merkliche Verminderung der Auflösung. Mit OBS hatte ich da ein etwas besseres Resultat, welches aber leider auch nicht mit den Frapsaufnahmen unter Win7 auf meinem alten PC mithalten kann. Mein Wunsch wäre es aber, auf jeden Fall eine gleiche, wenn nicht sogar bessere Qualität zu erreichen.

Da dürfte wohl @GabiB's Tipp mit Bandicam eine Alternative sein, die ich mal testen werde. Danke
anno-michi has attached the following file:
  • cpu-z log.txt (72.89 kB - 10 times downloaded - latest: Today, 5:14am)
  Spannende ANNO 1503 Let's Plays gibts auf meinem YouTubeChannel! :up:
Schau doch mal vorbei!

octo124

SeeBär

Posts: 250

Date of registration: Jan 13th 2007

  • Send private message

8

Sunday, January 13th 2019, 11:49pm

Tja, einmal sagt W10 "Minidump erstellt" und dann ist da nix - einer der kleineren Bugs. Aktiviere mal bitte https://www.win-10-forum.de/pc-fragen-pr…dumps-mehr.html
Ursachen könnten das veraltete BIOS in Verbindung mit den Boardtreibern sein. Leider werden heutzutage neue Boards niemals mehr mit einem bugfreien BIOS ausgeliefert - GigaByte glänzt da mit Abstand Mit Versionen an BIOS-Updates im Laufe der ersten Monate.

Treiber hast du aber anscheinend noch nicht manuell aktualisiert. Falls der Nvidia-Treiber anstandlos funktioniert, dann lasse ihn im jetzigen veralteten Zustand. Ansonsten aktualisieren und evt. without dieses "bescheidenen" Expierience https://forums.guru3d.com/threads/nvidia…utility.423072/
Und beachte den Tip zum Daktivieren des automatischen Treiberupdates - W10 denkt sehr oft, dass seine Boardtreiber besser sind als die des Herstellers.

"...Das Betriebssystem habe ich via USB Stick aufgespielt...." - hoffentlich hast du zuvor die HDD abgestöpselt. Kannst ja mal in der Datenträgerverwaltung nachschauen, wo die versteckte UEFI-Boot-Partition ist. Falls doch auf der HDD, dann lasse es dabei ( sind nur gefühlte Milisekundenverluste ) und denke beim nächsten Neuaufsetzen mal an diese Kleinigkeit.