Sie sind nicht angemeldet.

AnnoGrandpa

Frisch Angeheuert

  • »AnnoGrandpa« ist der Autor dieses Themas

Beiträge: 2

Registrierungsdatum: 27. März 2018

  • Nachricht senden

1

Dienstag, 27. März 2018, 20:29

Falsche Version - Meldung bei Multiplayer

Hallo, kurze Vorstellung...
Bin schon lange Annoplayer, hab erst mit 1701 angefangen, 1404 und 2070 hab ich auch, wobei mir 1701 immer noch am besten gefällt, aber das ist wohl Geschmacksache...

Aufmerksam wurde ich auf die Seite durch Google bei der Suche nach Problemlösungen...und da wären wir schon beim Thema

Nachdem ich Anno 1701 wieder "ausgegraben" habe und seit einiger Zeit wieder (solo) spiele, wollte ich mit der Tocher mal ein Multiplayer-spiel starten... (es sind 2 Originalspiele-DVD´s mit Heft und Seriennummer vorhanden (ver 1.0) sowie 2x von Green Pepper, die Version ohne Netzwerk (große Entäuschung), sowie 2x die Fluch des Drachen, 2x Anno 2070 und 1x 1404)

auf einen Rechner ist Win7 und auf einem Win10; beide auf ver 1.04 gepatcht (wird auch im Spielfenster angezeigt und in der Registry (hab googeln müssen) auch).

wir finden uns im Netzwerk, aber beim Beitreten kommt immer die Meldung "Falsche Version". Dabei ist egal wer das Spiel erstellt.

Nach unzähligem deinstallieren und neuinstallieren incl. entfernen der Registyeinträge (da musste ich auch erst googeln) besteht das Problem weiterhin.

Hab auch schon (um ev. Unterschiede der DVD´s auszuschließen) von einer DVD auf beide Rechner, dann patch...

Trotzdem, auf Win7 wird nicht nach einer Serial gefragt (zumindest nicht nach der letzten Installation), bei win10 schon (obwohl von der selben DVD installiert).
Die Registry hab ich mit der Serial nach Anleitung vervollständigt; Win 10 fragte dann trotzdem nach der Serial und der Eintrag ist nun 2 mal in der Registry!? (wurde erst selbstständig eingetragen als das Spiel als Admin gestartet wurde)

Es ist auch durchaus möglich, daß ich nicht alle Registryeinträge gefunden und entfernt habe.

Habe mittlerweile auch schon gelesen, daß es wohl bei den Versionen ein ziemliches Desaster gibt, beim dem wohl keiner so richtig durchblickt ?(.

Aber wenn ich auf beiden Rechner von der selben DVD installiere sollte das wohl alle versionstechnischen Inkompatibilitäten auschließen. Natürlich hab ich je eine DVD für jeden Rechner (wie oben erwähnt), ohne DVD läuft es ja nicht...

Unter win10 startet Anno ohne patch 1.04 gar nicht, also der patch ist zwingend notwendig.

ev. weiß hier jemnd Rat...

Johnny123

Landratte

Beiträge: 1

Registrierungsdatum: 29. März 2018

  • Nachricht senden

2

Donnerstag, 29. März 2018, 00:17

Hallo AnnoGrandpa,

ich habe eben dieses Forum entdeckt und ein paar Interessante Threads gelesen,
als ich auf deinen Post traf.

Witzigerweise hatte ich das Problem auch mit einem Freund, und konnte es nach mehrmaligen Versuchen beheben. Die Lösung war simpel aber nicht intuitiv:

Die Lösung war eine Portfreigabe am Router des Hosts.
Dort habe ich Port 9100 und 9103 (UDP) freigegeben.
Bei weiteren Fragen siehe: http://1404.annowiki.de/index.php?title=Router

Gruß
Johnny

PS: Ich spiele auch noch ab und zu Anno 1404 im Multiplayer, sag mal Bescheid, wenn ihr Spiel ;)

AnnoGrandpa

Frisch Angeheuert

  • »AnnoGrandpa« ist der Autor dieses Themas

Beiträge: 2

Registrierungsdatum: 27. März 2018

  • Nachricht senden

3

Samstag, 31. März 2018, 07:10

Danke für den Vorschlag, hat aber auch nicht geholfen; die "falsche Versions-Meldung" kommt nach wie vor.

GabiB

Schatzjäger

Beiträge: 1 881

Registrierungsdatum: 9. November 2003

  • Nachricht senden

4

Samstag, 31. März 2018, 13:50

Mal die Anleitung von Iceman durchgearbeitet? :wedel:
  :engel:

Gute Mädchen kommen in den Himmel, böse überall hin! Sprichwort

Soricida

Piratenschreck

Beiträge: 661

Registrierungsdatum: 30. Dezember 2011

  • Nachricht senden

5

Sonntag, 1. April 2018, 22:08

Moin AnnoGrandpa,

wie habt Ihr denn Eure PC's vernetzt???
Lan-Kabel = PC-Direktverbindung
Lan/W-Lan im Heimnetzwerk
Router/Modem Internet
oder,...

In welche Verzeichnisse wurden Anno 1701 + Der Fluch... installiert?

Wurde vor der Installation der neue Tages installiert?

Gruß
Soricida
  Ich bin ja nicht neugierig, aber wissen möchte ich es schon!

chippy

SeeBär

Beiträge: 272

Registrierungsdatum: 9. November 2008

  • Nachricht senden

6

Freitag, 20. April 2018, 21:57

Musste man die green pepper version nicht zuerst durch modifikation an einer datei multiplayer fähg machen?

Ich meine ich hatte dazu vor Jahren mal was geschrieben

Guten Tag,



nach mehreren Versuchen habe ich eine Möglichkeit gefunden, wie man den Multiplayer Button wieder anzeigen lassen kann.

Hier die Anleitung von "Das Goldene Schiff"



Zuerst benötigt ihr den Rda-Packer von Sir Henry, zu finden hier.

Damit entpackt ihr dann die "data8.rda", zu finden im Anno 1701 Verzeichnis.

Jetzt den entstandenen Ordner "data8" öffnen.

Ihr müsst nun in der Datei "mainmenu2", zu finden im data8 Ordner
/data/config/gui/menudefinitions, nach "03MAIN_MULTIPLAYER_BUTTON"
suchen (mit einem Editor der Wahl, z.B. mit dem Windows Editor).

Ihr solltet folgendes finden:




Aufklappen um Inhalt zu lesen







Scrollt etwas hinunter, bis zu den Zeilen




Aufklappen um Inhalt zu lesen







Diese ersetzt ihr durch




Aufklappen um Inhalt zu lesen









Im Rda-Packer wählt ihr nun in dem "data8" Ordner den "data" Ordner aus und klickt auf "Einpacken".

Speichert die Datei unter dem Namen "data8.rda" ab und ersetzt damit die Original Datei.